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Function Changes (Design Mode)
This document is intended to help users transition from UQ Reportal 4.2 to UQ Reportal 4.3. 
This document provides a guide to locating functions in the previous version of UQ Reportal when working on a report in Design mode in the upgraded environment. It lists the toolbars, contextual menus and explains where each item is in the new UQ Reportal. 
If you are looking for a high-level overview of BO 4.3 changes, see the UQ Reportal resources - Overview of Changes. 
Reading mode: If you are working on reports in Reading mode, a UQ Reportal resources - Function Changes (Reading Mode) document is available.
Contents
Toolbar - File Tab
[image: ]
New
In the File section on the toolbar. You can also create a new report by clicking the Web Intelligence tile from the BI Launch Pad.
[image: ]
Open
In the File section on the toolbar. Alternatively, from the BI Launch Pad, navigate to the report and open it.
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Save/Save As
In the File section of the toolbar. The options are the same, however the layout of the Save As screen has changed.
In the upgraded version, the Save As options into three separate tabs, compared to all options being on one screen in BO 4.2. The folder structure and file name fields are on the General tab. The description, key words, and setting checkboxes are on the Options tab. The Assign Categories selection is on the Categories tab.
[image: ]
Print
In the File section of the toolbar. No changes to the print options however the layout has changed.
[image: A screenshot of a computer

Description automatically generated with medium confidence][image: ]
Find
No longer on toolbar. To search the document, use the browser's Find function.
History
No longer on the toolbar. To view the history of instances of a document, from the BI Launch Pad, navigate to the document, click the ellipsis on the document tile or row, and select History.
[image: ]
Export
In the File section of the toolbar.  The layout of the Export function has changed. All options are now located in the same screen and include exporting to HTML. 
[image: ]
Send To
Send to User is available from the ellipsis in the File section of the toolbar as Send to BI Inbox:
[image: A screenshot of a computer screen

Description automatically generated with low confidence]
The pop-up screen for sending a report to a user has been redesigned. You search for and select users on the Select Users/Groups tab. As with similar selection screens in the updated version, the move arrows have been replaced with checkboxes. The options for setting a target name and the type of file to send (copy or shortcut) are now on the Send Options tab.[image: ]

Undo/Redo
In the File section of the toolbar.
[image: ]

Cut/Copy/Paste
Use your keyboard shortcuts or the contextual menu. The below shows the menu when a data cell is selected and right clicked. The menu differs based on the selected element; however, if available, Cut, Copy and Paste are still near the top of each contextual menu.
[image: ]
Delete
Use your keyboard shortcuts or the contextual menu by click right in on the selected element.
[image: ]
Edit Data Provider
On the toolbar. Query > Edit.
[image: ]
The Query Panel that displays is the same as in BO 4.2 except for button and tab locations. In 4.3, the buttons for Run, Apply Changes and Close (no longer under the Close drop-down list), and Cancel (replaces Revert Changes and Close option under the Close drop-down list) are at the bottom of the screen. If a report as multiple queries, they are listed near the top of the screen in 4.3[image: ]
Refresh
On the toolbar. Query > Refresh.
[image: ]
The drop-down list has options to refresh all the queries, or an Advanced refresh which allows for refresh of specific queries. The Prompts screen that displays has the same options but in a different interface

[image: A screenshot of a computer
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Toolbar - Properties Tab
[image: screenshot of the BO 4.2 Design Mode Toolbar showing only the Properties tab section]
View drop-down list (Filter Bar, Outline, Formula Bar, Side Panel, Report Tabs, Status Bar)
Filter bar
On toolbar - Analyze > Filter Bar 
The Filter Bar shows currently available/applied Input Controls and Drill filters.
[image: ]
Outline
On toolbar - Display > Ellipsis icon > Fold/Unfold
[image: ]
Formula Bar
On toolbar - Analyze > Formula Bar 
[image: ]
Side Panel
The image below shows the location of the Main Panel which opens and closes the panel.
[image: ]
Report Tabs
Individual report tabs can be hidden in 4.3 by selecting Hide from the drop-down list in the report tab. If a tab is hidden, it has the Hide icon next to its name.
[image: ]
Status Bar
There is no Status bar. You can access these features from the Display and Navigate sections.
[image: ]
Application (Measurement setting)
Now access from Settings. From BI Launch Pad, click the circle with your initial in the upper-right corner, select Settings > Application Preferences to change the Measurement Unit setting.
[image: ]
Toolbar - Report Elements Tab
[image: ]
Tables Tab
On toolbar - Insert > Insert Table  > Vertical/Horizontal/Cross/Form.
[image: ]





Cell Tab
On toolbar - Insert > Insert Cell.
The separate Blank button in 4.2 is now included in the pre-defined options in the drop-down list, as shown below.
[image: ]

Section Tab
On toolbar - Insert > Insert section.
After clicking in the report to add a section, the Define a New Section window displays. This was called Available Objects in 4.2 but it functions the same way.
[image: ]
Chart Tab
On toolbar - Insert > Insert Chart  
The image below shows the location of Insert Chart on the 4.3 toolbar and the various chart options.
[image: ]



Once the chart is added to the report, the process of adding data has changed. 
In 4.2, objects are dragged from the Available Objects sidebar and dropped directly onto the chart (or by right clicking and Assigning Data).
[image: ]

When a chart is added to a report in 4.3, the Data/Format panel opens, showing the Report Element Data and Feeding panel. The Data Assignment section expands and you can then drag and drop the desired objects (From the document dictionary in the Main panel) into the feeding panel or in the chart directly.
[image: ]







Tools Tab
Turn into
On Data/format panel - Report element data > Feeding panel
[image: ]
Set as section
Right click on cell and select Set as section
[image: ]
Position Tab
Order
Right click on cell and select Order
Below image shows the contextual menu that displays when you right click on an element. Selecting Order displays the order options.

[image: ]







Align
Below image shows the contextual menu that displays when you right click on one or multi-select elements. Selecting Format table cell > Text settings displays the alignment options in the data/format panel on the right. 
[image: ]
Alternatively, you can access from the Data/format panel > Show report element format > Text settings.
[image: ]
Linking Tab
Links will only function in Reading Mode, so you will need to revert from Design Mode to test.
[image: ]
Hyperlink
Right click on element and select Hyperlink
[image: ]
Element
Two options:
Right click on element and select Element Link
Below shows how to access Element Link and its sub-options from a contextual menu:
[image: ]
OR
Data/format panel > Show report element data > Element Link.
Below shows how to access Element Link from the Data/Format panel
[image: ]

Table Layout Tab
[image: ]
Break
Two options:
Right click on element and select Data > Add Break
[image: ]



Or
Data/format panel > Show report element data > Break panel.
Below shows how to access the Break panel from the Data/Format panel
[image: ]

Insert
Right click on element and select Insert
[image: ]

Header/Footer
Data/format panel > Show report element data > Break panel > Table Layout.
[image: ]
Or
Data/format panel > Show report element data > Display settings.
[image: ]
Behaviours/Cell Behaviours/Section Behaviours Tabs
[image: ]
Hide (Table)
Two options:
Right click on table and select Hide
[image: ]
Or
Data/format panel > Show report element data > Display settings
[image: ]

Hide (Column)
Right click on the cell and select Hide
[image: ]

Page Break/Repeat
Select table > Data/format panel > Show report element data > Layout settings
[image: ]
Section Layout Tab
[image: ]
Select section > Data/format panel > Show report element data > Layout settings
[image: ]
Toolbar - Formatting Tab
[image: ]
Select section > Data/format panel > Show report element data panel.
In the below example, the layout settings appear when a cell is selected. The sub-tabs and settings are different depending on the type of element selected (e.g., cell, table, section):
[image: ]

Toolbar - Data Access Tab
[image: ]

Data Providers Tab
Edit
On toolbar – Query > Edit.
[image: ]
There are minor differences between the Query Panel screens. In 4.3, the buttons for Run, Apply Changes and Close (no longer under the Close drop-down list), and Cancel (replaces Revert Changes and Close option under the Close drop-down list) are at the bottom of the screen. If a report has multiple queries, they are listed near the top of the screen in 4.3.[image: ]
Purge
On toolbar – Query > ellipsis > Purge Data.
[image: ]

Refresh
On toolbar – Query > Refresh.
[image: ]
The drop-down list has options to refresh all the queries, or an Advanced refresh which allows for refresh of specific queries. The Prompts screen that displays has the same options but in a different interface.
[image: A screenshot of a computer

Description automatically generated with medium confidence]

Tools Tab
On toolbar – Query > ellipsis > Change Source
[image: ]



Data Objects Tab
[image: ]
New Variable 
Two options:
Main Panel > Document Dictionary > ellipsis > Add a new variable
[image: ]
OR
Create variable from the formula bar.
[image: ]
Assign Reference
Right-click on the element and select Assign Reference.
[image: ]







Merge
Main Panel > Document Dictionary 
Select the dimensions being merged using Ctrl and select the ellipsis on the last dimension selected.
In the below example, the Application Year object under the QTAC query was second selected.
[image: ]

Toolbar - Analysis Tab
[image: ]
Filters Tab
[image: A picture containing text, font, software, line

Description automatically generated]
Filter
Two options:
Data/Format Panel > Report element data > Filter panel
[image: ]






Or
Right click on the element - Data > Add Filter, which opens the panel shown above.
A new filter is created in 4.3 by dragging the filter element from the Main Panel > Document dictionary onto the Filter panel then configuring the data in the window that displays.
[image: ]
Ranking
Data/Format Panel > Report element data > Ranking panel

[image: ]
Input Controls
On the Filter Bar. Toggle the Filter Bar from the toolbar. Analyze > Filter Bar
[image: ]




Data Tracking Tab
[image: A screenshot of a computer
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On toolbar – Analyze > ellipsis > Track Data Changes and Show Changes
[image: ]

Display Tab
Group
On Main panel – Document dictionary > ellipsis next to the object > Manage Groups
[image: ]
Break
Two options:
Right click on element and select Data > Add Break
[image: ]
Or
Data/format panel > Show report element data > Break panel.
Below shows how to access the Break panel from the Data/Format panel.
[image: ]
Sort
On Data/Formatting panel – Report element data > Sort
[image: ]
You can also sort from the contextual menu by right clicking in the cell and selecting Data> Sort which opens the panel above.
[image: ]
Conditional Tab
Two options:
Toolbar – Analyze > ellipses > Formatting Rules
[image: ]


Or
Right clicking in the cell and selecting Data> Sort which opens the panel above.
[image: ]
Interact Tab
Drill
Toolbar – Analyze > Drill
[image: ]
Filter
On Data/Formatting panel – Report element data > Filter bar
[image: ]
Outline
Toolbar – Display > Fold/Unfold
[image: ]
Functions Tab
Right click on the cell and select Footer calculation > desired option
[image: ]

Toolbar - Page Setup Tab
[image: ]
Report, Report Name, Move Report Tabs
In the drop-down list next to the report name you can access the various report.
[image: ]
Page, Header, Footer, Scale to Page, Margins, Display Tabs
On Data/Formatting panel – Report element format > Display settings > Appearance Setting and Layout settings panels.
[image: ]
Contextual Menus
Contextual menus are accessed by right-clicking on a report element. The four main contextual elements listed below.
Report Contextual Menu
 [image: ]
The options have changed in 4.3
· Cut, Copy, Paste - Cut and copy options are not available from the menu in 4.3. Paste displays in the 4.3 menu if there is something on the clipboard that can be pasted.
· Insert - The elements to insert (e.g., table, report element, etc.) are accessed from the Insert section of the toolbar.
· Refresh - Available on the toolbar.
· Show Structure / Show Results - Available on Main Panel > Show Report Structure; since this is a panel in 4.3 now, the Show Results option is no longer needed.
· Start Drill - Available from the ellipsis in the Analyze section of the toolbar
Options on both menus:
· Filter - Data in 4.3
· Format Report – Data/Format panel
New BO 4.3 option:
Copy Link of the Report – Copies URL of the document
Hide - Hides the report
Section Contextual Menu
[image: ]
The options have changed in 4.3
· Cut, Copy, Paste - Cut and copy options are not available from the menu in 4.3. Paste displays in the 4.3 menu if there is something on the clipboard that can be pasted.
· Insert - The elements to insert (e.g., table, report element, etc.) are accessed from the Insert section of the toolbar.
· Refresh - Available on the toolbar.
· Report - There are several options under this selection in BO 4.2:
· Show Structure / Show Results - Available on Main Panel > Show Report Structure; since this is a panel in 4.3 now, the Show Results option is no longer needed..
· Start Drill / Show Changes - Available on the toolbar > Analyze > ellipsis.
· Format Report - Available on the Data/Format panel > Report Element Format Report.

Options on both menus:
· Edit Section
· Hide
· Delete
· Filter & Sort - Filter and Sort are under Data
· Format Section
New option:
Copy Link of the Section


Table Contextual Menu
[image: ]
The options have changed in 4.3
· Align - Available on Data/Format panel > Report Element Format > Layout Settings.
· Linking – Split out to Element Link and Shared Element
· Comment – No longer available.

Options on both menus:
· Cut, Copy - Paste 
· Delete
· Turn Into
· Assign Data
· Filter, Sort & Break – All are under Data
· Hide
· Order
· Format Table

New option:
Open Document – Copies URL of document
Freeze Header 

Cell Contextual Menu
[image: ]

The options have changed in 4.3
Turn Into - Available on Data/Format panel > Report Element Data > Feeding panel
Edit Formula - To see the current formula for a cell, click the Formula Bar in the Analyze section of the toolbar. The bar displays above the report. To edit the formula, click Display the formula editor on the Formula bar.
Drill - Available from the ellipsis in the Analyze section of the toolbar.
Group - Available from the Main Panel > Document dictionary; click the ellipsis next to an object and select Manage Groups.
Comment - 
Options on both menus:
Cut, Copy - Paste 
Comment – No longer available.
Insert - The Count, Min, and Max options are now under Footer Calculation.
Delete
Merge/Unmerge
Clear Contents - Under Content.
Set as Section
Linking - This is now called Element Link.
Assign Reference
Filter, Ranking, Sort & Break - These functions are under Data.
Hide
Formatting Rules
Format Number - Under Format Display 
Format Cell/Text - Under Format Table Cell and changes are made in the Report element format panel.
New BO 4.3 option:
Footer Calculation - The Sum, Count, Average, Min, Max and Percentage options has been expanded to include ‘Default Aggregation’.
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